CVM Class Library 7.0 (legacy)

The library is distributed under the Boost Software License, Version 1.0. This is version 7.0, January 6th, 2013 (see also history of changes and FAQ page). It's left here for backward compativility only and is no longer supported. Please upgrade to the latest version.

The following compilers and integrated development environments are supported by this version:

For even older compilers please use versions 5.6.2 and 5.2.

If you want to rebuild Fortran subroutines included into the library, you'll also need Intel Fortran 11.1 or higher for Win32 and Linux platform (gfortran is also supported under Linux and MingW). The library can be linked with Intel MKL 10.2 or higher, with AMD ACML 4.3.0 or higher and also with native BLAS and LAPACK implementations. Your questions, feature requests and bug reports are very welcome at

Copyright (c) Sergei Nikolaev, 1992-2013. Welcome to my personal page. Logo